Category : package

Hello There im new to laravel and want to use spatie’s query builder package for filtering and sorting but this issue occurs while installing. Problem 1 – spatie/laravel-query-builder[3.5.0, …, v3.x-dev] require illuminate/database ^6.20.13|^7.30.4|^8.22.2 -> found illuminate/database[v6.20.13, …, 6.x-dev, v7.30.4, 7.x-dev, v8.23.1, …, 8.x-dev] but it conflicts with another require. – Root composer.json requires spatie/laravel-query-builder ^3.5 ..

Read more

$ composer require intervention/image Using version ^2.5 for intervention/image ./composer.json has been updated Running composer update intervention/image Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages. Problem 1 – intervention/image[2.5.0, …, 2.5.1] require guzzlehttp/psr7 ~1.1 -> found guzzlehttp/psr7[1.1.0, …, 1.x-dev] but the package is ..

Read more

IlluminateDatabaseQueryException : SQLSTATE[42000]: Syntax error or access violation: 1103 Incorrect table name ” (SQL: create table “ (id int unsigned not null auto_increment primary key, description longtext not null, userType varchar(191) not null, userId int null, route longtext null, ipAddress varchar(45) null, userAgent text null, locale varchar(191) null, referer longtext null, methodType varchar(191) null, created_at ..

Read more

is there any library of video can concatenate (vid 1 + vid 2) for more example i have user model he or she upload the video i want to concatenate intro video on my own with user upload video to make 1 video with intro and he/she video i’m using laravel and upload video with ..

Read more

I’m trying to develop my own package for laravel by tutorial, and when i’ve added info about provider to app.php (step#5) and trying make controller(step#6). I’m getting Class ‘IchwillkinTestikTestikServiceProvider’ not found an i’ve tried composer dump-autoload-nothing is changed. Here is package composer.json: { "name": "ichwillkin/testik", "type": "library", "authors": [ { "name": "Ich Will", "email": "[email protected]" ..

Read more

I am not sure if this is a correct channel for the package question, But I am using this package, https://github.com/antonioribeiro/countries. Documentation is not much clear. I can get currency symbol with the below code, $all = $countries->where(‘name.common’, ‘India’)->first()->hydrateCurrencies()->currencies; dd($all->INR->units->major->symbol); But in the second line of code, I must specify INR to get the symbol. ..

Read more

I am trying to install westpac payway rest api package- Omnipay: PayWay REST API https://github.com/rotassator/omnipay-payway-restapi I did install dependent packages- guzzle, league/omnipay then omnipay/common But the driver package available for payment gateway Westpac Payway having a dependency issue with omnipay/common enter image description here if anyone helps to install this. I am using laravel 8.4 ..

Read more

I created a file packages/webgrig/restrict-wordlist-passwords/composer.json { "name": "webgrig/restrict-wordlist-passwords", "description": "A package to restrict users from using wordlist-based passwords", "license": "MIT", "version": "1.0.0", "authors": [ { "name": "webgrig", "email": "[email protected]" } ], "minimum-stability": "dev", "require": {} } Then in the main composer.json file i wrote the following sections "autoload": { "psr-4": { "App": "app/", "WebgrigRestrictWordlistPasswords": "packages/webgrig/restrict-wordlist-passwords" ..

Read more

I created a file packages/webgrig/restrict-wordlist-passwords/composer.json { "name": "webgrig/restrict-wordlist-passwords", "description": "A package to restrict users from using wordlist-based passwords", "license": "MIT", "version": "1.0.0", "authors": [ { "name": "webgrig", "email": "[email protected]" } ], "minimum-stability": "dev", "require": {} } Then in the main composer.json file i wrote the following sections "autoload": { "psr-4": { "App": "app/", "WebgrigRestrictWordlistPasswords": "packages/webgrig/restrict-wordlist-passwords" ..

Read more

I want to install web3 package with Laravel 8. But I get this error on Terminal: Problem 1 – Root composer.json requires sc0vu/web3.php dev-master -> satisfiable by sc0vu/web3.php[dev-master]. – sc0vu/web3.php dev-master requires guzzlehttp/guzzle ~6.0 -> found guzzlehttp/guzzle[6.0.0, …, 6.5.x-dev] but it conflicts with your root composer.json req uire (^7.3). And my Composer.json goes like this: ..

Read more

composer require maatwebsite/excel Using version ^3.1 for maatwebsite/excel ./composer.json has been updated Running composer update maatwebsite/excel Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages. Problem 1 – maatwebsite/excel[3.1.27, …, 3.2.x-dev] require phpoffice/phpspreadsheet ^1.16 -> satisfiable by phpoffice/phpspreadsheet[1.16.0, 1.17.0, 1.17.1]. – maatwebsite/excel 3.1.26 requires ..

Read more

I am using this package for enabling Cors on the webserver. I have added the Cors Middleware as mentioned in the documentation protected $middleware = [ AppHttpMiddlewareTrustProxies::class, AppHttpMiddlewarePreventRequestsDuringMaintenance::class, FruitcakeCorsHandleCors::class, IlluminateFoundationHttpMiddlewareValidatePostSize::class, AppHttpMiddlewareTrimStrings::class, IlluminateFoundationHttpMiddlewareConvertEmptyStringsToNull::class, AppHttpMiddlewareForceJsonResponse::class, AppHttpMiddlewareDecryptEnquiryId::class, ]; And this is how my cors.php looks return [ ‘paths’ => [‘api/*’], ‘allowed_methods’ => [‘*’], ‘allowed_origins’ => [‘*’], ‘allowed_origins_patterns’ => ..

Read more

I am using Laravel for API development. I have been using different packages to ease the development as well as saving more time and effort and focus more on the business code. Such packages include: barryvdh/laravel-debugbar intervention/image spatie/laravel-permission spatie/laravel-activitylog barryvdh/laravel-dompdf anlutro/l4-settings maatwebsite/excel psalm/plugin-laravel Aside from default Laravel packages, do you have any packages to recommend ..

Read more

I’m building a Laravel Package. I need to publish my custom migrations. One migration need another one to be run because it has a foreign key constraint. In my service provider I’m doing this: public function boot(Filesystem $filesystem) { $this->loadMigrationsFrom(dirname(__DIR__).’/migrations’); $this->publishMigrations($filesystem); } private function publishMigrations(Filesystem $filesystem) { if (! class_exists(‘CreateReferencedTable’)) { $this->publishes([ __DIR__ . ‘/../database/migrations/create_referenced_table.php.stub’ ..

Read more

I Just Update My Composer Which Returns with some errors and issues: Your requirements could not be resolved to an installable set of packages. Problem 1 – jeremykenedy/laravel-roles v1.2.0 requires laravel/framework 5.3.*|5.4.*|5.5.*|5.6.* -> found laravel/framework[v5.3.0-RC1, …, 5.6.x-dev] but it conflicts with your root composer.json require (^8.0). – jeremykenedy/laravel-roles v1.3.0 requires laravel/framework 5.3.*|5.4.*|5.5.*|5.6.*|5.7.* -> found laravel/framework[v5.3.0-RC1, ..

Read more