Category : installation

h have problem when try to step laratrust with laravel 7 Your requirements could not be resolved to an installable set of packages. Problem 1 – santigarcor/laratrust[5.0.0, …, 5.0.x-dev] require illuminate/auth ~5.2 -> found illuminate/auth[v5.2.0, …, 5.8.x-dev] but these were not loaded, likely because it conflicts with another require. – Root composer.json requires santigarcor/laratrust 5.0.* ..

Read more

https://laravel.com/docs/8.x#getting-started-on-linux I created the install directory, example-app, ran the curl command, didn’t run the sail up, but the directory was populated when I checked before removing it. Then I repeated what I’d just did (changed my mind), but get this: [email protected]:~/Docker_$ curl -s "https://laravel.build/example-app?with=pgsql,mariadb,redis,memcached,meilisearch,minio,selenium,mailhog" | bash _ _ | | | | | | __ ..

Read more

I have the detail when using the command `composer install` I have the following errors `Installing dependencies from lock file (including require-dev) Verifying lock file contents can be installed on current platform. Your lock file does not contain a compatible set of packages. Please run composer update. Problem 1 – phpoffice/phpspreadsheet is locked to version ..

Read more

Im trying install the Algolia PHP SDK via the Composer package manager for a Laravel Nova project im doing using the following command line: composer require algolia/algoliasearch-client-php -W and I get the following problems: mylaravelnovaproject composer require algolia/algoliasearch-client-php -W Using version ^3.1 for algolia/algoliasearch-client-php ./composer.json has been updated Running composer update algolia/algoliasearch-client-php –with-all-dependencies Loading composer ..

Read more

I am running with some issues in laravel project installation. When I am using the command composer update it shows following errors: PS C:xampphtdocsltp-site-audit-crawler> composer install Installing dependencies from lock file (including require-dev) Verifying lock file contents can be installed on current platform. Your lock file does not contain a compatible set of packages. Please ..

Read more

I Am Trying To Install Laravel Into My Kali Linux From This Documentation https://www.linuxhelp.com/how-to-install-laravel-in-debian, But At End When I Am Executing php artisan key:generate This Command It Through An Error What Should I Do Now?? Did Anyone Have Any Other Option That How I Can Install It In My Kali linux. Sourc..

Read more

This is a duplicate question, 100%. …I have tried a great many solutions from other answers, which haven’t worked. I searched for the errors with site:github.com, which may indicate it is a Laravel issue and not necessarily a PyroCMS 3 issue. I have searched here– I found plenty of people that have asked the same ..

Read more

"require": { "php": "^7.3|^8.0", "fideloper/proxy": "^4.4", "fruitcake/laravel-cors": "^2.0", "guzzlehttp/guzzle": "^7.0.1", "intervention/image": "^2.5", "laravel/framework": "^8.12", "laravel/tinker": "^2.5", "laravel/ui": "^3.2", "tymon/jwt-auth": "^1.0" }, this is my composer.json. now I need to add laravel/passport but it is giving some errors because of version conflicts with Tymon/jwt-auth. Laravel version:- v8.53.1 laravel/passport version: v10.1.3 composer require laravel/passport Using version ^10.1 ..

Read more

IlluminateDatabaseQueryException : SQLSTATE[42000]: Syntax error or access violation: 1103 Incorrect table name ” (SQL: create table “ (id int unsigned not null auto_increment primary key, description longtext not null, userType varchar(191) not null, userId int null, route longtext null, ipAddress varchar(45) null, userAgent text null, locale varchar(191) null, referer longtext null, methodType varchar(191) null, created_at ..

Read more

[ComposerExceptionNoSslException] The OpenSSL extension is required for SSL/TLS protection but is not available. If you can not enable the OpenSSL extension, you can disable this error, at your own risk, by setting the ‘disable-tls’ option to true. create-project [-s|–stability STABILITY] [–prefer-source] [–prefer-dist] [–repository REPOSITORY] [–repository-url REPOSITORY-URL] [–add-repository] [–dev] [–no-dev] [–no-custom-installers] [–no-scripts] [–no-progress] [–no-secure-http] [–keep-vcs] [–remove-vcs] ..

Read more

[ComposerExceptionNoSslException] The OpenSSL extension is required for SSL/TLS protection but is not available. If you can not enable the OpenSSL extension, you can disable this error, at your own risk, by setting the ‘disable-tls’ option to true. create-project [-s|–stability STABILITY] [–prefer-source] [–prefer-dist] [–repository REPOSITORY] [–repository-url REPOSITORY-URL] [–add-repository] [–dev] [–no-dev] [–no-custom-installers] [–no-scripts] [–no-progress] [–no-secure-http] [–keep-vcs] [–remove-vcs] ..

Read more

I have just created a new Laravel project and installed Bootstrap right off the bat: composer require laravel/ui php artisan ui bootstrap npm install && npm run dev Now it also automatically installs resolve-url-loader: Additional dependencies must be installed. This will only take a moment. Running: npm install [email protected]^3.1.2 –save-dev –legacy-peer-deps Which returns: Finished. Please ..

Read more

iam installed laravel project using laravel documents details.and installed my project into my lampp directory path (htdocs/myproject).After that i run my project in browser.But i didt get the intro page of laravel showing Permission denied messege Like: The stream or file "/opt/lampp/htdocs/dotgo/storage/logs/laravel.log" could not be opened in append mode: Failed to open stream: Permission denied ..

Read more

when I whrite this in cmd Creating a "laravel/laravel" project at "./example-app" the command shows the following error: [ErrorException] curl_setopt(): Unable to create temporary file. create-project [-s|–stability STABILITY] [–prefer-source] [–prefer-dist] [–repository REPOSITORY] [–repository-url REPOSITORY-URL] [–add-repository] [–dev] [–no-dev] [–no-custom-installers] [–no-scripts] [–no-progress] [–no-secure-http] [–keep-vcs] [–remove-vcs] [–no-install] [–ignore-platform-req IGNORE-PLATFORM-REQ] [–ignore-platform-reqs] [–ask] [–] [<package>] [<directory>] [<version>] PS E:xampphtdocsproject1> [ErrorException] ..

Read more

according to the laravel documentation on the official laravel website, to install breeze, you must type the command "composer require laravel/breeze –dev". After executing this command, you must then type "php artisan breeze:install". However, the execution of the second command gives us an error message which is:"There are no commands defined in the "breeze" namespace". ..

Read more