Category : https

I have a question about force using HTTPS in laravel, i’ve added a condition inside AppServiceProvider.php, creating a middleware and modifying the .htaccess file. But I can still access the http page. Is there any other way to get laravel to redirect to https instead of http, and how to prevent user to acces the ..

Read more

im working with laravel project.. and i have this problem: Mixed Content: The page at ‘https://xxxxxx/admin/dashboard’ was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ‘http://xxxxxx/admin/dashboard/order_statics/September’. This request has been blocked; the content must be served over HTTPS. <IfModule mod_rewrite.c> <IfModule mod_negotiation.c> Options -MultiViews -Indexes </IfModule> RewriteEngine On # Handle Authorization Header RewriteCond %{HTTP:Authorization} ..

Read more

Buenos dias Developers hoy me encuentro en una situación anteriormente ya habia usado livewire de laravel para mis proyectos pero no me habia enfrentado a esto tengo un dominio de un sistema en operacion me solicitaron mejoras e implemente livewire sabemos que para publicar los assets de livewire se debe publicar los archivos con php ..

Read more

I am trying to force my laravel project to use https instead of http, and i tried everything : i added these lines to my HTACCESS file : RewriteEngine On RewriteCond %{HTTPS} !=on RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] i used AppServiceProvider : use IlluminateSupportFacadesURL; URL::forceScheme(‘https’); i did through the middleware too, but my URL doesn’t seem ..

Read more

I’m working on web app with php v. is 7.4.16, the laravel version is 8.31.0. When i run my FrontEnd project with global API_URL which is hosted on Linux, everything work. But when i clone the API from git-hub and run it and add LOCAL_URL in the FrontEnd i get a error like this when ..

Read more

I’m trying to download composer from official site, the error that I’m getting is <<<< Warning: copy(): Unable to find the wrapper "https" – did you forget to enable it when you configured PHP? in Command line code on line 1 Warning: copy(): Unable to find the wrapper "https" – did you forget to enable ..

Read more

I have hosted my Lumen(version : 5.7.8), in my apache server. The site has been accessed using https. So in AppProvidersAppServiceProvider I have added public function boot() { URL::forceScheme(‘https’); } When I run swagger,which I have installed using DarkaOnline, it is showing blank page and got the following error in the console. Uncaught ReferenceError: SwaggerUIBundle ..

Read more

I have a problem, my website is running on Laravel 5, I have set up SSL cert and configured it using Load Balancer in AWS. Set up listeners for HTTP(80) and HTTPS(443). SSL checker seems fine. I can access https://www.mydomainname.com and it directs to a secure page. However everytime I enter www.mydomainname.com on any browser ..

Read more

Forcing to redirect URI from http to https using Laravel 5.4 on Heroku Method I used to solve this problem: APP_URL: https://stackoverflow.com/a/45891292/6607216 MiddleWare: https://stackoverflow.com/a/45858789/6607216 Proxies: https://gist.github.com/ilhamsj/819369a56bb983eac018c5f4e04cda50 I tried to upgrade Laravel version to 5.6 and 5.8 but no luck also. Kind of wondering if Heroku is blocking something to privent redirect from http to https. ..

Read more

I successfully deployed a Laravel application on Apache Ubuntu 20.04 in Digital Ocean, everything was fine until I installed CertBot software to configure HTTPS on my Apache server. After installing and setting up certbot, when i visit the homepage via HTTPS:// link, it works fine but when I tried to visit other pages via HTTPS:// ..

Read more

I have a middleware to rediret to HTTPS like so: <?php namespace AppHttpMiddleware; use Closure; use IlluminateHttpRequest; class HttpsProtocolMiddleware { public function handle($request, Closure $next) { if (!$request->secure() && app()->environment(‘production’)) { dd("need to redirect"); return redirect()->secure($request->getRequestUri()); } return $next($request); } } however it is not working since if go to https://project.domain.com i get a "too ..

Read more

i installed laravel 7 with laravel-admin.org 1.6 6 month ago. then last month i upgrade it to laravel 8 and laravel-admin 1.8 in my local everything is ok but in my server after config https with .htaccess file RewriteCond %{HTTPS} off RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] when i go to /admin after login with my admin ..

Read more

My site has SSL configured successfully, now I want to force HTTPS in app/Providers/RouteServiceProvider.php but it never works for me. Already know .htaccess way but I want to try this. I wonder if this works without touching .htaccess. <?php namespace AppProviders; use IlluminateFoundationSupportProvidersRouteServiceProvider as ServiceProvider; use IlluminateSupportFacadesRoute; use IlluminateSupportFacadesURL; class RouteServiceProvider extends ServiceProvider { … ..

Read more