Category : auth0

I am using Laravel 7 and I want to create an API auth0 middleware for my application. I used this auth0 guide: https://auth0.com/docs/quickstart/backend/laravel/01-authorization#define-permissions by I also found this one which is quite similar: https://auth0.com/blog/build-and-secure-laravel-api/ When I try to use the /api/private route (which uses the jwt mention middleware) I get the following error which drives ..

Read more

I am attempting to upgrade auth0/auth0-php to version 7.3.0 as available on GitHub here This is part of my process to upgrade Laravel from 7.x to 8.x. In composer.json, I have the following defined as required: "require": { "php": "^7.2.5", "doctrine/dbal": "^2.10", "auth0/auth0-php": "^7.3", "fideloper/proxy": "^4.2", "fruitcake/laravel-cors": "^1.0", "guzzlehttp/guzzle": "^7.0.1", "laravel/framework": "^8.0", "laravel/tinker": "^2.0", "twilio/sdk": ..

Read more