Category : adminlte

I’m trying to call a module route from an AdminLTE submenu but it says: syntax error, unexpected token ":", expecting "(" I’m writing at the top of file ‘views/vendor/partials/sidebar/menu-item-link.blade.php’ 2 lines but it is probably breaking with the first one: @if( !isset($item[‘module’]) || (Module::has($item[‘module’]) ) And of course in the adminlte.php configuration file I add ..

Read more

In my Laravel project, I have the following models: Product (‘name’ string, ‘amount’ integer and ‘price’ decimal) Cart (‘cost’ decimal) CartProd (‘unit_price’ decimal, ‘amount’ integer, ‘discount’ decimal, ‘total_cost’ decimal and foreign keys to a product and a cart) The idea is that, when you want to create a new cart, the CartController method creates a ..

Read more

I have a ClassController which sends $players & $classPlayers collections to a view. /** * Show the form for editing the specified resource. * * @param int $id * @return IlluminateHttpResponse */ public function edit($id) { $classe = Classe::findOrFail($id); $players = User::whereRoleIs([‘player’])->get(); $classePlayers = User::where(‘classe_id’, ‘=’, $classe->id)->get(); return view("admin.classes.edit", compact(‘classe’, ‘players’, ‘classePlayers’)); } the collection ..

Read more

I discovered a link to integrate adminLTE in laravel 8 and I follow it. Here is the link https://levelup.gitconnected.com/integrating-adminlte-3-and-laravel-8-51c1555efa60 but when im going to use jquery’s document.ready and toastr. It says $ not defined or toastr not defined. Im not installing jquery or toastr since I assume its included in adminLTE as the docs said. ..

Read more

I need to Update the Logo on the Laravel AdminLTE on runtime based on a value from Database, as currently it is handled by the adminlte.php config file. I have tried passing a global variable (say $logoUrl) to every view with View Composers and then I use javascript to change the logo src value. document.addEventListener("DOMContentLoaded", ..

Read more

When I click on the menu it works on child menus (see this image) but after clicking any of those menus the parent menu does not show as active like this. I’ve also added the html code of that section. ` @php $routeName = Request::route()->getName();$prefixName = Request::route()->getPrefix(); @endphp <li class="nav-item {{ ($prefixName == ‘/manage/users’) ? ..

Read more

The adminlte sidebar menu is not working in laravel safari I have tried <a href="#" class="sidebar-toggle" role="button" data-toggle="push-menu"> <span class="sr-only">Toggle navigation</span> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </a> <ul class="sidebar-menu" data-widget="tree"> but not worked in safari. When I give the data-toggle="offcanvas" is working in macos chrome, firefox. No issues in windows browsers. Any help or ..

Read more

I’m using adminlte template for laravel(https://github.com/jeroennoten/Laravel-AdminLTE) and made a vue.js component. Component itself is working fine, but adminlte css and js is not working. I have added app.js and app.css files in @section tags like it was written in adminlte docs. Here’s my code where I link the files: @section(‘css’) <link rel="stylesheet" href="{{ asset(‘css/app.css’) }}"/> ..

Read more