Problem to upgrade laravel 5.8 to 6.0 composer update

  composer-php, laravel, laravel-6, php

I need upgrade to laravel 5.8 to 6.0 I have this issues

Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
– illuminate/support[v5.7.2, …, 5.7.x-dev] require nesbot/carbon ^1.26.3 -> found nesbot/carbon[1.26.3, …, 1.39.1] but it conflicts with your root composer.json require (2.24.0 as 1.26.0).
– illuminate/support v5.6.39 requires nesbot/carbon 1.25.* -> found nesbot/carbon[1.25.0, 1.25.1, 1.25.3] but it conflicts with your root composer.json require (2.24.0 as 1.26.0).
– laravel/framework[v6.19.0, …, 6.x-dev] require nesbot/carbon ^2.31 -> found nesbot/carbon[dev-master, 2.31.0, …, 2.x-dev (alias of dev-master)] but it conflicts with your root composer.json require (2.24.0 as 1.26.0).
– Root composer.json requires laravel/passport 7.2 -> satisfiable by laravel/passport[v7.2.0].
– Conclusion: don’t install laravel/framework v6.0.2 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.0.3 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.0.4 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.1.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.2.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.3.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.4.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.4.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.5.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.5.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.5.2 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.6.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.6.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.6.2 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.7.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.8.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.9.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.10.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.10.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.11.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.12.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.13.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.13.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.14.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.15.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.15.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.16.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.17.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.17.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.2 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.3 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.4 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.5 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.6 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.7 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.8 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.9 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.10 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.11 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.12 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.13 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.14 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.15 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.16 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.17 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.18 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.19 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.20 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.21 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.22 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.23 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.24 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.25 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.26 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.27 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.28 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.29 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.30 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.31 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.32 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.33 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.34 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.35 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.36 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.37 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.38 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.39 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.40 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.41 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.42 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.43 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.0.1 (conflict analysis result)
– laravel/passport v7.2.0 requires illuminate/support ~5.6.0|~5.7.0|~5.8.0 -> satisfiable by illuminate/support[v5.6.0, …, 5.8.x-dev].
– Only one of these can be installed: illuminate/support[v5.1.1, …, 5.8.x-dev, v6.0.0, …, 6.x-dev, v7.0.0, …, 7.x-dev, v8.0.0, …, 8.x-dev], laravel/framework[v6.0.0, …, 6.x-dev]. laravel/framework replaces illuminate/support and thus cannot coexist with it.
– Root composer.json requires laravel/framework ^6.0 -> satisfiable by laravel/framework[v6.0.0, …, 6.x-dev].

This is my composer.lock

{
"name": "laravel/laravel",
"description": "The Laravel Framework.",
"keywords": ["framework", "laravel"],
"license": "MIT",
"type": "project",
"require": {
    "php": "^7.2",
    "aws/aws-sdk-php": "^3.158",
    "barryvdh/laravel-cors": "^0.11.2",
    "doctrine/dbal": "~2.3",
    "fideloper/proxy": "^4.0",
    "guzzlehttp/guzzle": "^6.3",
    "kamranahmedse/smasher": "^1.0",
    "laravel/framework": "^6.0",
    "laravel/passport": "7.2",
    "laravel/tinker": "^1.0",
    "lcobucci/jwt": "3.3.3",
    "predis/predis": "^1.1",
    "nesbot/carbon": "2.24.0 as 1.26.0"
},
"require-dev": {
    "beyondcode/laravel-dump-server": "^1.0",
    "filp/whoops": "^2.0",
    "fzaninotto/faker": "^1.4",
    "kamranahmedse/smasher": "^1.0",
    "mockery/mockery": "^1.0",
    "nunomaduro/collision": "^3.0",
    "phpunit/phpunit": "^8.0"
},
"autoload": {
    "classmap": [
        "database/seeds",
        "database/factories"
    ],
    "psr-4": {
        "App": "app/"
    }
},
"autoload-dev": {
    "psr-4": {
        "Tests": "tests/"
    }
},
"extra": {
    "laravel": {
        "dont-discover": [
        ]
    }
},
"scripts": {
    "post-root-package-install": [
        "@php -r "file_exists('.env') || copy('.env.example', '.env');""
    ],
    "post-create-project-cmd": [
        "@php artisan key:generate"
    ],
    "post-autoload-dump": [
        "IlluminateFoundationComposerScripts::postAutoloadDump",
        "@php artisan package:discover"
    ]
},
"config": {
    "preferred-install": "dist",
    "sort-packages": true,
    "optimize-autoloader": true
},
"minimum-stability": "dev",
"prefer-stable": true

}

Source: Laravel

Problem to upgrade laravel 5.8 to 6.0 composer update

I need upgrade to laravel 5.8 to 6.0 I have this issues

Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
– illuminate/support[v5.7.2, …, 5.7.x-dev] require nesbot/carbon ^1.26.3 -> found nesbot/carbon[1.26.3, …, 1.39.1] but it conflicts with your root composer.json require (2.24.0 as 1.26.0).
– illuminate/support v5.6.39 requires nesbot/carbon 1.25.* -> found nesbot/carbon[1.25.0, 1.25.1, 1.25.3] but it conflicts with your root composer.json require (2.24.0 as 1.26.0).
– laravel/framework[v6.19.0, …, 6.x-dev] require nesbot/carbon ^2.31 -> found nesbot/carbon[dev-master, 2.31.0, …, 2.x-dev (alias of dev-master)] but it conflicts with your root composer.json require (2.24.0 as 1.26.0).
– Root composer.json requires laravel/passport 7.2 -> satisfiable by laravel/passport[v7.2.0].
– Conclusion: don’t install laravel/framework v6.0.2 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.0.3 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.0.4 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.1.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.2.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.3.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.4.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.4.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.5.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.5.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.5.2 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.6.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.6.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.6.2 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.7.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.8.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.9.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.10.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.10.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.11.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.12.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.13.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.13.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.14.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.15.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.15.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.16.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.17.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.17.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.0 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.1 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.2 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.3 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.4 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.5 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.6 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.7 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.8 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.9 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.10 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.11 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.12 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.13 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.14 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.15 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.16 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.17 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.18 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.19 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.20 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.21 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.22 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.23 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.24 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.25 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.26 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.27 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.28 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.29 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.30 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.31 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.32 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.33 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.34 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.35 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.36 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.37 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.38 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.39 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.40 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.41 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.42 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.18.43 (conflict analysis result)
– Conclusion: don’t install laravel/framework v6.0.1 (conflict analysis result)
– laravel/passport v7.2.0 requires illuminate/support ~5.6.0|~5.7.0|~5.8.0 -> satisfiable by illuminate/support[v5.6.0, …, 5.8.x-dev].
– Only one of these can be installed: illuminate/support[v5.1.1, …, 5.8.x-dev, v6.0.0, …, 6.x-dev, v7.0.0, …, 7.x-dev, v8.0.0, …, 8.x-dev], laravel/framework[v6.0.0, …, 6.x-dev]. laravel/framework replaces illuminate/support and thus cannot coexist with it.
– Root composer.json requires laravel/framework ^6.0 -> satisfiable by laravel/framework[v6.0.0, …, 6.x-dev].

This is my composer.lock

{
"name": "laravel/laravel",
"description": "The Laravel Framework.",
"keywords": ["framework", "laravel"],
"license": "MIT",
"type": "project",
"require": {
    "php": "^7.2",
    "aws/aws-sdk-php": "^3.158",
    "barryvdh/laravel-cors": "^0.11.2",
    "doctrine/dbal": "~2.3",
    "fideloper/proxy": "^4.0",
    "guzzlehttp/guzzle": "^6.3",
    "kamranahmedse/smasher": "^1.0",
    "laravel/framework": "^6.0",
    "laravel/passport": "7.2",
    "laravel/tinker": "^1.0",
    "lcobucci/jwt": "3.3.3",
    "predis/predis": "^1.1",
    "nesbot/carbon": "2.24.0 as 1.26.0"
},
"require-dev": {
    "beyondcode/laravel-dump-server": "^1.0",
    "filp/whoops": "^2.0",
    "fzaninotto/faker": "^1.4",
    "kamranahmedse/smasher": "^1.0",
    "mockery/mockery": "^1.0",
    "nunomaduro/collision": "^3.0",
    "phpunit/phpunit": "^8.0"
},
"autoload": {
    "classmap": [
        "database/seeds",
        "database/factories"
    ],
    "psr-4": {
        "App": "app/"
    }
},
"autoload-dev": {
    "psr-4": {
        "Tests": "tests/"
    }
},
"extra": {
    "laravel": {
        "dont-discover": [
        ]
    }
},
"scripts": {
    "post-root-package-install": [
        "@php -r "file_exists('.env') || copy('.env.example', '.env');""
    ],
    "post-create-project-cmd": [
        "@php artisan key:generate"
    ],
    "post-autoload-dump": [
        "IlluminateFoundationComposerScripts::postAutoloadDump",
        "@php artisan package:discover"
    ]
},
"config": {
    "preferred-install": "dist",
    "sort-packages": true,
    "optimize-autoloader": true
},
"minimum-stability": "dev",
"prefer-stable": true

}

Source: Laravel

Leave a Reply