Can’t install Jetstream package to Laravel project

  composer-php, jetstream, laravel, laravel-8, php

I use Laravel 8 framework. PHP version is 7.4. After running command

composer require laravel/jetstream

I have some errors:

Your requirements could not be resolved to an installable set of
packages.

Problem 1
– laravel/jetstream 1.x-dev requires laravel/fortify ^1.0 -> satisfiable by laravel/fortify[1.x-dev, v1.0.0, v1.0.1, v1.1.0,
v1.2.0, v1.2.1, v1.3.0, v1.3.1, v1.4.0, v1.4.1, v1.4.2, v1.4.3,
v1.5.0, v1.6.0, v1.6.1, v1.6.2].
– laravel/jetstream v1.5.0 requires laravel/fortify ^1.0 -> satisfiable by laravel/fortify[1.x-dev, v1.0.0, v1.0.1, v1.1.0,
v1.2.0, v1.2.1, v1.3.0, v1.3.1, v1.4.0, v1.4.1, v1.4.2, v1.4.3,
v1.5.0, v1.6.0, v1.6.1, v1.6.2].
– laravel/jetstream v1.5.1 requires laravel/fortify ^1.0 -> satisfiable by laravel/fortify[1.x-dev, v1.0.0, v1.0.1, v1.1.0,
v1.2.0, v1.2.1, v1.3.0, v1.3.1, v1.4.0, v1.4.1, v1.4.2, v1.4.3,
v1.5.0, v1.6.0, v1.6.1, v1.6.2].
– laravel/fortify 1.x-dev requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.0.0 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.0.1 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.1.0 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.2.0 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.2.1 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.3.0 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.3.1 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.4.0 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.4.1 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.4.2 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.4.3 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.5.0 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.6.0 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.6.1 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– laravel/fortify v1.6.2 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
– bacon/bacon-qr-code 2.0.2 requires ext-iconv * -> the requested PHP extension iconv is missing from your system.
– bacon/bacon-qr-code 2.0.1 requires ext-iconv * -> the requested PHP extension iconv is missing from your system.
– bacon/bacon-qr-code 2.0.0 requires ext-iconv * -> the requested PHP extension iconv is missing from your system.
– Installation request for laravel/jetstream ^1.5 -> satisfiable by laravel/jetstream[1.x-dev, v1.5.0, v1.5.1].

To enable extensions, verify that they are enabled in your .ini
files:
– /etc/php/php.ini
– /etc/php/conf.d/igbinary.ini
– /etc/php/conf.d/redis.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

Installation failed, reverting ./composer.json to its original
content.

I have read some manuals, but I didn’t see similar errors. Please, help.

Source: Laravel

Leave a Reply