Cannot upgrade laravel 7 to laravel 8

  composer-php, laravel, laravel-8, php

I am trying to upgrade my laravel project from laravel 7 to 8 and got this error:

Your requirements could not be resolved to an installable set of packages.


Problem 1
    - Conclusion: don't install laravel/framework v8.3.0
    - Conclusion: don't install laravel/framework v8.2.0
    - Conclusion: don't install laravel/framework v8.1.0
    - Conclusion: don't install laravel/framework v8.0.4
    - Conclusion: don't install laravel/framework v8.0.3
    - Conclusion: don't install laravel/framework v8.0.2
    - Conclusion: don't install laravel/framework v8.0.1
    - laravel/dusk v5.11.0 requires illuminate/support ~5.7.0|~5.8.0|^6.0|^7.0 -> satisfiable by laravel/framework[v7.25.0], illuminate/support[5.7.17, 5.7.18, 5.7.19, v5.7.0, v5.7.1, v5.7.10, v5.7.11, v5.7.15, v5.7.2, v5.7.20, v5.7.21, v5.7.22, v5.7.23, v5.7.26, v5.7.27, v5.7.28, v5.7.3, v5.7.4

….. some very long list of illuminate versions…..

- don't install illuminate/console v6.8.0|don't install laravel/framework v8.0.0
    - Installation request for laravel/framework ^8.0 -> satisfiable by laravel/framework[v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.2.0, v8.3.0].
    - Installation request for laravel/dusk ^5.0 -> satisfiable by laravel/dusk[v5.0.0, v5.0.1, v5.0.2, v5.0.3, v5.1.0, v5.1.1, v5.10.0, v5.11.0, v5.2.0, v5.3.0, v5.4.0, v5.5.0, v5.5.1, v5.5.2, v5.6.0, v5.6.1, v5.6.2, v5.6.3, v5.7.0, v5.8.0, v5.8.1, v5.8.2, v5.9.0, v5.9.1, v5.9.2].

Below are the requirements in composer.json

"require": {
        "php": ">=7.4.2",
        "laravel/framework": "^8.0",
        "laravel/tinker":"^2.0",
        "intervention/image": "^2.3",
        "barryvdh/laravel-elfinder": "0.4.*",
        "guzzlehttp/guzzle": "^7.0.1",
        "khill/lavacharts": "^3.1.0",
        "laravelcollective/html": "^6.0",
        "laravel/ui": "^3.0",
        "binarytorch/larecipe": "^2.3",
        "doctrine/dbal": "^2.10"
    },
    "require-dev": {
        "fzaninotto/faker": "^1.9",
         "mockery/mockery": "^1.4",
        "phpunit/phpunit": "^9.0",
        "symfony/thanks": "^1.0",
        "filp/whoops": "^2.7",
        "laravel/dusk": "^5.0",
        "kitloong/laravel-migrations-generator": "^4.4"
    },

What might be the problem and how to fix it?

Source: Laravel

Leave a Reply